Drupal soluciona una vulnerabilidad que afecta a su librería CKEditor. ¡Actualiza ahora!

Publicado por: Manuel Abreu Ortiz - social@manuelabreuo.com

Se ha detectado un fallo de seguridad de criticidad alta en el core de Drupal, en concreto en la librería CKEditor, que sirve para editar páginas desde el backend de la web. Este fallo podría permitir a un ciberdelincuente realizar ataques del tipo Cross-Site Scripting (XSS).

Solución: 

Se recomienda actualizar Drupal a la última versión disponible, para ello puedes acceder a los siguientes enlaces:

  • Si utilizas Drupal 9.2, actualice a Drupal 9.2.9.
  • Si utilizas Drupal 9.1, actualice a Drupal 9.1.14 (las anteriores versiones no recibirán actualizaciones por estar al final de su vida útil).
  • Si utilizas Drupal 8.9, actualice a Drupal 8.9.20 (versión final de Drupal 8 que alcanza su fin de vida útil).

Las versiones anteriores a la 8.9.x y versiones anteriores a 9.1.x no reciben actualizaciones de seguridad por estar descontinuadas.

Importante: recuerda hacer una copia de seguridad de los archivos de tu servidor y de la base de datos antes de proceder a actualizar tu gestor de contenidos. Además, es recomendable realizar pruebas previas en entornos de preproducción y comprobar que todo funciona correctamente tras la actualización.

Es importante proteger el gestor de contenidos para evitar que sea vulnerable. Sigue este checklist para evitar posibles ataques de ciberdelincuentes, algunos de ellos explicados en casos reales:

Esta actualización corrige una vulnerabilidad que afecta al core de Drupal que utiliza la librería de terceros CKEditor. Esta librería proporciona funciones de editor de texto HTML/ WYSIWYG de código abierto a las páginas web. Esta vulnerabilidad permitiría inyectar código HTML con formato incorrecto sin pasar por la desinfección del contenido, lo que podría conducir a un ataque XSS o secuencias de comandos en sitios cruzados (del inglés Cross-Site Scripting).

Este problema solo afecta a los sitios con CKEditor activado con versiones anteriores a la 4.17.0. Además, esta actualización corrige un bug.

Info – INCIBE