Moodle ha corregido varias vulnerabilidades críticas. ¡Actualiza!

Publicado por: Manuel Abreu Ortiz - social@manuelabreuo.com

La plataforma de formación Moodle ha publicado varias actualizaciones de seguridad, entre las que se encuentran algunas con severidad crítica, que permitirían la ejecución de código remoto, realizar ataques de tipo cross-site request forgery y de tipo reflected cross-site scripting.

Solución

Se recomienda actualizar Moodle a la última versión disponible. Para ello, puedes acceder al siguiente enlace:

Si utilizas otra versión de Moodle que continúa con soporte, puedes acceder a los enlaces de descarga que corrigen la vulnerabilidad.

Importante: antes de actualizar en entornos de producción es recomendable realizar pruebas previas en entornos de preproducción y comprobar que todo funciona correctamente tras la actualización.

Es importante proteger el gestor de contenidos para evitar que sea vulnerable. Sigue esta checklist para evitar posibles ataques de ciberdelincuentes, algunos de ellos explicados en casos reales:

La actualización de seguridad corrige varias vulnerabilidades, entre las cuales están las siguientes con severidad crítica:

  • Ejecución de código remoto al restaurar una copia de seguridad con un archivo con un formato incorrecto.
  • La función delete related badge no incluía la verificación de token, lo que podría permitir un cross-site request forgery.
  • Un parámetro de URL en la herramienta de administrador del sitio filetype requería una sanitización adicional para evitar un riesgo de reflected cross-site scripting.

Info – INCIBE